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Presenter

• Presenter
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Sr. Application Engineer
Lambda Research Corporation

• Moderator
Mike Gauvin
Vice President of Sales and Marketing
Lambda Research Corporation



Format

• A 25-30 minute presentation followed by 
a question and answer session

• Please submit your questions anytime 
using Question box in the GoToWebinar
control panel



Additional Resources

• Past TracePro Webinars

• https://www.lambdares.com/su/tracepro-webinars/

• TracePro Tutorial Videos

• https://www.lambdares.com/su/tracepro-videos/

• TracePro Tutorials

• https://www.lambdares.com/su/tracepro-tutorials/

• Information on upcoming TracePro Training Classes

• https://www.lambdares.com/training/

https://www.lambdares.com/su/tracepro-webinars/
https://www.lambdares.com/su/tracepro-videos/
https://www.lambdares.com/su/tracepro-tutorials/
https://www.lambdares.com/training/


Upcoming TracePro Training

• Tel Aviv, Israel

• 1-day TracePro seminar – October 16, 2017

• Littleton, MA

• Introduction to TracePro – October 24-25, 2017

• Optimization with TracePro – October 26-27, 2017

• Barcelona, Spain

• Introduction to TracePro – November 7-8, 2017

• Optimization with TracePro– November 9-10, 2017

• Please ask us about custom onsite training



Latest TracePro and RayViz Release

TracePro 7.8.1 - Released May 3, 2017

TracePro 7.8.2 Early Access - Now available

RayViz 7.8.1 - Released May 3, 2017

Customers with current maintenance and support agreements can 
download this new release at:

http://www.lambdares.com/CustomerSupportCenter/index.php/trace-pro/current-release

http://www.lambdares.com/CustomerSupportCenter/index.php/trace-pro/current-release
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Agenda

• What property types are available in TracePro

• Which properties are available in each edition of TracePro

• The parameters that define different property types

• The property editors and how to make new properties

• Utilities in TracePro for making new properties

• Questions and Answers



Property Types in TracePro



Property Types in TracePro

Properties applied to objects

• Material

• Bulk Scattering

• Fluorescence

• Gradient Index

• Mueller Matrix

• Raytrace Flag

• Importance Sampling (for Bulk Scattering)

• Temperature

• Color

Properties shown in Red have a dedicated property editor



Property Types in TracePro

Properties applied to surfaces

• Surface

• RepTileTM

• Color

• Importance Sampling (surface scattering, surface source, and 
diffraction)

• Exit Surface

• Diffraction

• Surface Source

• Temperature

• Temperature Distribution

Properties shown in Red have a dedicated property editor



Property Types in TracePro

Properties are stored in the TracePro property database

• Typical location of TracePro property database:

C:\Users\username\AppData\Roaming\Lambda Research Corporation\
TracePro\TracePro.db

• Database location can be found at View->Options->General

• Tools->Database->Export – Saves current model properties as a text file

• Tools->Database->Import – Import new properties



Property Types Available in Each Edition of 
TracePro



Property Types in TracePro LC

• Surface

• Material

• Surface Source

• Color

• Exit Surface

• Raytrace Flag



Property Types in TracePro Standard

• Surface

• Material

• Surface Source

• Color

• Exit Surface

• Raytrace Flag

• Bulk Scatter

• Diffraction

• Gradient Index

• Importance Sampling

• Mueller Matrix

• Temperature

• Class and User Data

• Prescription

• Thin Film Stack



Property Types in TracePro Expert

• Surface

• Material

• Surface Source

• Color

• Exit Surface

• Raytrace Flag

• Bulk Scatter

• Diffraction

• Gradient Index

• Importance Sampling

• Mueller Matrix

• Temperature

• Class and User Data

• Prescription

• Thin Film Stack

• Fluorescence

• RepTile

• Temperature 
Distribution



TracePro Property Parameters



TracePro Property Parameters

For complete information on all of the TracePro property parameters, 
please see Chapter 3 of the TracePro User Manual.

The TracePro User Manual is available in TracePro at:

Help->TracePro User Manual



TracePro Property Parameters

Each property type will have its own set of unique parameters that are 
used to define the property. In many cases these parameters can vary as 
a function of other values such as temperature, wavelength, incident 
angle, or azimuth angle.



TracePro Property Parameters

• Index of Refraction

• Table

• Interpolation Formula

• Schott, Sellmeier, Extended Schott, Herzberger, Conrady, Sellmeier 2, Sellmeier 3, 
Sellmeier 4, Handbook 1, Handbook 2, Hikari

• Bulk Absorption 

• Absorption Coefficient - defined by Beer-Lambert Law

• Extinction Coefficient

• Minimum and Maximum Wavelength

• Isotropic or Uniaxial

• Temperature

Material Property



TracePro Property Parameters

• Absorption

• Specular Reflection

• Specular Transmission

• BRDF (bidirectional reflectance distribution function) – reflected scatter

• BTDF (bidirectional transmittance distribution function) – transmitted scatter

• BRDF and BTDF can be either Isotropic or Asymmetric Scatter

• Temperature

Surface Property

Scattering BRDF and BTDF can be: ABg, Elliptical ABg, Elliptical Gaussian, 
Table BSDF, Asymmetric Table BSDF, 1D ABg, 1D Table, or Use BSDF 
Properties. TracePro LC is limited to ABg. All of the scatter models are 
available in both TracePro Standard and Expert.



TracePro Property Parameters

• Spectral Type

• Rectangular, Gaussian, Solar, Table

• Angular Type

• Lambertian, Gaussian, Uniform, Solar, and Table

• Emission

• Watt/m2, Watt, Lux, Lumen

• Temperature

Surface Source Property

Selecting the Table option for Spectral and Angular type gives you 
complete control of the emission as a function of wavelength, polar angle, 
azimuth angle, and temperature.



TracePro Property Parameters

• Scatter Model

• Henyey-Greenstein, Gegenbauer, User Defined

• Anisotropy (g)

• Likely direction of scatter: g=0 - isotropic scatter, g<0 - backwards scatter,   
g>0 - forward scatter

• Scatter Coefficient (μs)

• Inverse of the mean free path

• Alpha

• Used in the Gegenbauer scatter model

Bulk Scatter Property



TracePro Property Parameters

• Relative Absorption vs. Excitation Wavelength

• Relative Extinction vs. Excitation Wavelength

• Relative Emission vs. Emission Wavelength

• Temperature

Fluorescence Property



TracePro Property Parameters

• Gradient Index model type

• Axial-Radial, Axial Elliptical, Axial-Sinusoidal-Radial, Axial-Tapered-Radial, 
SELFOC, Wood Lens, Spherical, Fisheye, Luneburg, GRADIUM (Buchdahl), 
GRADIUM (Sellmeier)

• Relevant Coefficients for selected Gradient Index model

Gradient Index Property



TracePro Property Parameters

• Variation Type

• Geometry

• Tile Type

• Bump or Hole

• Tile Parameters

• Geometry Type parameters

RepTile Property

Please see our webinar on “RepTile and the Texture Optimizer II”

https://www.lambdares.com/support/reptile-property-texture-optimizer-ii/



TracePro Property Parameters

• Material 

• Thickness

Thin Film Stack Property

The Thin Film Stack is referenced by a Surface Property to model a thin 
film coating applied to a surface. 



The Property Editors in TracePro



TracePro Property Editors

• Material

• Surface

• Surface Source

• Bulk Scattering

• Fluorescence

• Gradient Index

• RepTile

• Thin Film Stack

These properties have dedicated property editors to define their 
parameters. Other properties such as Temperature, Mueller Matrix, and 
Importance Sampling have their parameters defined in the relevant Apply 
Properties dialog box.



TracePro Property Editors

Properties Editors can be found at Define->Edit Property Data

The property editors available will depend on the edition of TracePro 
being used. TracePro Expert shown above.



TracePro Property Editors

Surface Property Editor



TracePro Property Editors

Material Property Editor



TracePro Property Editors

Surface Source Property Editor



TracePro Property Editors

Bulk Scatter Property Editor



TracePro Property Editors

Fluorescence Property Editor



TracePro Property Editors

Gradient Index Property Editor



TracePro Property Editors

RepTile Property Editor



TracePro Property Editors

Thin Film Stack Editor



Making New Properties in TracePro



Making New Properties in TracePro

Steps for making a new property in TracePro

1. Open the relevant property editor

2. Click Add Catalog if you want to add a new catalog to the database

3. Click Add Property

4. Enter a name for the property

5. Choose options for the property if necessary

6. Enter the required data for the property

7. Click the disk icon to save the property



Making New Properties in TracePro

Surface Property Example – Open Surface Property Editor



Making New Properties in TracePro

Surface Property Example – Open Surface Property Editor



Making New Properties in TracePro

Surface Property Example – Add a new Catalog if needed



Making New Properties in TracePro

Surface Property Example – Add a new Property



Making New Properties in TracePro

Surface Property Example – Select the Scatter Model



Making New Properties in TracePro

Surface Property Example – Surface Property Editor



Making New Properties in TracePro

Surface Property Example – Enter initial parameters



Making New Properties in TracePro

Surface Property Example – Use Solve For to solve for additional 
parameters such as BRDF



Making New Properties in TracePro

Surface Property Example – Surface Property with initial data entered



Making New Properties in TracePro

Surface Property Example – Use Data Points->Add to add additional lines 
to the spreadsheet



Making New Properties in TracePro

Surface Property Example – Use Data Points->Delete to add remove lines 
from the spreadsheet



Making New Properties in TracePro

Surface Property Example – Click the disk icon to save the property



Making New Properties in TracePro

Surface Property Example – Click the lock icon to unlock the property for 
editing



Making New Properties in TracePro

Surface Property Example – Import and Export property icons



Making New Properties in TracePro

Surface Property Example – Properties in TracePro are text files. They 
can be created and modified in a text editor, Excel, or similar program.

Stock properties cannot be edited or modified. To modify a stock property, 
make a copy of it and then edit the copy.



TracePro Utilities for Making New Properties



TracePro Utilities for Making Properties

TracePro utilities for making new properties can be found at: 

Define->Generate Property Data



TracePro Utilities for Making Properties

BSDF Converter Utility

Convert measured BSDF data to Surface Properties for use in TracePro



TracePro Utilities for Making Properties

Surface Source Property Utility

Use graphs from LED datasheets to make new Surface Source 
Properties for use in TracePro. Please see out tutorial video:
https://www.lambdares.com/support/making-led-surface-source-property-1280x720-resolution/



TracePro Utilities for Making Properties

Fluorescence Property Utility

Use graphs for Excitation, Emission, Absorption, and Source Spectrum to 
make Fluorescence properties for use in TracePro



TracePro Utilities for Making Properties

DMD Texture Utility

Make custom DMD RepTile properties using a Bitmap or JPEG image



TracePro Utilities for Making Properties

Surface Property Utility – new in TracePro 7.8.2

Convert measured BSDF data to Surface Properties for use in TracePro 
including composite BSDF properties



Summary and Questions



Summary and Questions

The TracePro allows you to define new, custom optical properties at any 
time:

Open property database allows users to add new properties to the 

database

 Adding new properties is easy and straightforward

 A wide variety of property parameters to accurately model different 

property types

 Properties can be easily shared between users

 TracePro utilities are available to help with defining some property types

For more information or to sign up for our free 30-day trial please visit us at:

www.lambdares.com

Phone: +1 978-486-0766         E-mail: sales@lambdares.com

http://www.lambdares.com/
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