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Format 

•A 25-30 minute presentation followed by a 

question and answer session 

 

•Please submit your questions anytime using 

Question box in the GoToWebinar control panel 
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Webinar Topics: 

•Using Simulation Mode : how, when, and why. 

 

•Determining memory usage using the Windows Task 

Manager and the TracePro Raytrace Report 

 

•Modifying multiple Surface Sources at one time using the 

Surface Source Editor 

 

•Grouping and moving System Tree items for better 

organization 

 

•Display options, shortcuts to move and orbit the model 

view 



Webinar Topics: 

•What is the “Detect Rays Starting in Bodies” setting and 

when you should use it 

 

•Irradiance Map and Candela Plot tools to get more 

information out of your results 

 

•Interactive Optimizer settings 

 

•And many other topics….. 

 

•Question and Answer session 

 
 

 



Additional Resources 

•Past TracePro Webinars 
•http://www.lambdares.com/webinars/ 

 

•TracePro Tutorial Videos 
•http://www.lambdares.com/videos/ 

 

•TracePro Tutorials 
•http://www.lambdares.com/technical_support/tracepro/tutorials/ 

 

•TracePro Training Classes 
•http://www.lambdares.com/technical_support/training/ 

http://www.lambdares.com/webinars/
http://www.lambdares.com/videos/
http://www.lambdares.com/technical_support/tracepro/tutorials/
http://www.lambdares.com/technical_support/training/


Current TracePro Release 

•TracePro 7.1.2 

 

•TracePro 7.1.3 Early Access 

 

•Can be downloaded by anyone with a 

current Maintenance and Support Agreement 

 

•www.lambdares.com 
 

 



Tips, Tricks, and Shortcuts to Improve 

Productivity and Efficiency with TracePro 



The Simulation Mode Raytrace 



Analysis Mode 

•The default raytrace mode in TracePro is Analysis Mode 

 

•Ray data is saved on every surface in the model, in RAM. This can 

use large amounts of memory, but it allows you to view plots such 

as Irradiance Maps, 3D Irradiance Maps, and Candela Plots on any 

surface at any time 

 

•32-bit TracePro can only use up to 2GB of RAM, so it is easy to 

exceed the available amount of RAM with large or complex models 

and raytraces 

 

•64-bit  TracePro can use as much RAM as is available on your 

computer. This is better, but large raytraces may still exceed the 

available RAM. 

 

•Simulation Mode is the solution 
 



Simulation Mode 

•Simulation Mode raytrace 

 

•Predefine Exit Surface or Surfaces where you want to save the ray 

data 

 

•User can also choose to save Candela and Ray Path data 

 

•Ray data is saved to the hard drive instead of RAM 

 

•Creates a .sim file in the same directory as the model 

 

•Rays are not shown 

 
 



Simulation Mode 

Defining an Exit Surface, or Exit Surfaces 



Simulation Mode 

Simulation Mode Options 



Simulation Mode 

Simulation Mode Options 

Checking “Collect Path Sort 

Data” can increase raytrace 

times. If you are not looking 

at Path Sort data, leave this 

unchecked. The default 

setting is unchecked in the 

newest releases of TracePro 



Simulation Mode 

Switching to Simulation Mode 



Simulation Mode 

Running a Simulation Mode Raytrace 



Simulation Mode 

Simulation Mode Raytrace Results 



Simulation Mode 

Use the Simulation File Manager and the .sim file to open an Irradiance Map for  

a previous Simulation Mode raytrace 



Simulation Mode 

Typical Workflow using Simulation Mode 

 

Higher resolution results for 

Irradiance Maps, Candela 

Plots, etc.. 

 

 

Run initial raytraces in 

Analysis Mode with low 

number of rays 

 

 

Refine the model 

 

 

Switch to Simulation Mode 

 

 

Increase the number of rays 

traced 

 

 

Create Initial Model 

 



Determining Memory Usage by TracePro 



Determining Memory Usage 

Example Model - LED light with 7 LEDs and circular lens array 



Determining Memory Usage 

Windows Task Manager Performance Tab – Windows 7 64-bit 

Run a smaller number of rays initially to determine memory usage 

No rays traced 

2.89GB of RAM 

Model and other 

programs open 

350k rays traced 

3.62GB of RAM 

0.73GB used 

 

3.5M rays traced 

7.49GB of RAM 

4.6GB used 

 



Determining Memory Usage 

TracePro Raytrace Report – Reports->Raytrace 



Determining Memory Usage 

TracePro Raytrace Report – Reports->Raytrace 

350k rays traced 

0.194GB used for raytrace 

3.5M rays traced 

1.94GB used for raytrace 



Determining Memory Usage 

Why is there a difference in the RAM used as reported by the Windows 

Task Manager opposed to the TracePro Raytrace Report? 

The TracePro Raytrace Report only shows the amount of memory used 

for the raytrace itself. Additional tasks such as displaying the rays, 

opening an Irradiance Map or a Candela Plot, etc… consume additional 

memory. 

 

The Windows Task Manager is the more accurate method for 

determining memory usage and availability. 



Using the Surface Source Editor to Modify 

Applied Surface Source Properties 



Surface Source Editor 

Example Model - LED light with 7 LEDs and circular lens array 



Surface Source Editor 

Use the Surface Source Editor to modify any or all of the Surface Sources in a 

TracePro model – Define->Surface Source Editor 



Surface Source Editor 

Click on a column header to select all of the Surface Sources, or select 

individual sources in the spreadsheet, then click Modify to enter changes. 

Values can be Scaled or Set To a discrete value. Catalog and Name can only 

be edited one at a time in the Surface Source Editor. 



Advanced Select 

To apply a different Surface Source Property to each source in the model at 

one time, use Edit->Select->Advanced to select all of the Surface Sources with 

a given name. The Surface Source Property can then be changed for all of the 

selected sources using the Apply Properties Dialog Box. 

Valid in TracePro 7.1.3 EA 



Moving and Grouping Objects in the Model 

Tree for Better Organization 



Organizing the Model Tree 

To move objects in the Model Tree, right click in the Model Tree and select 

Enable Drag/Drop. Then select the object to move with the left mouse button 

and move it to its new location 



Organizing the Model Tree 

To add Object Groups to the Model Tree, right click in the Model Tree and 

select New Group Object. Then name the new Object Group and drag the 

objects into that group. 



Organizing the Model Tree 

Adding Object Groups can help organize the Model Tree and make objects 

easier to identify and locate. It can also make for a more compact Model Tree 

as Groups can be collapsed when not being used. 



Shortcuts for Panning and Orbiting 

 the Model View 



Panning and Orbiting the Model View 

Select the appropriate icon in the toolbar and the hold down the left mouse 

button in the model window to pan or orbit the model 

Pan icon Orbit icon 



Panning and Orbiting the Model View 

•Ctrl-right click and drag to pan the view 

 

•Shift-right click and drag to orbit the view 

 

•Drag on one of the axes of the 3 colored XYZ axes to rotate 

the view 

 

•Double click on an axis to make it point into the screen 

 

•Double click on the shaded arc between the colored axes to 

display a plan view 



Detect Rays Starting in Bodies 



Detect Rays Starting in Bodies 

TracePro assumes rays are starting in air. This can give the wrong result if rays 

are started inside an object with a different index of refraction. 

Air 

Acrylic 

n=1.49 



Detect Rays Starting in Bodies 

When starting rays inside an object, check the box for “Detect Ray Starting in 

Bodies” at Raytrace->Raytrace Options->Options 

Air 

Acrylic 

n=1.49 



Getting More Information from the 

Irradiance/Illuminance Maps and Candela Plots 



Irradiance/Illuminance Maps 

Example Model - LED light with 7 LEDs and circular lens array 

We want to see 

where these rays 

are coming from 

“Receiver” Surface 



Irradiance/Illuminance Maps 

Illuminance Map on “Receiver” Surface – Log Scale 

We want to see 

where these rays 

are coming from 



Irradiance/Illuminance Maps 

Select area of interest by Shift- left mouse click and dragging a box around 

the area of interest 



Irradiance/Illuminance Maps 

To display the selected rays, go to Analysis->Display Selected Rays, or right click in 

the Irradiance/Illuminance Map window and choose Display Selected Rays 



Irradiance/Illuminance Maps 

To display the selected rays, go to Analysis->Display Selected Rays, or right click in 

the Irradiance/Illuminance Map window and choose Display Selected Rays 

Higher flux rays 

are “leaking” 

around the 

edge of the 

lens element. 

Painting the 

space between 

the lens 

elements black 

would solve the 

problem. 



3D Irradiance/Illuminance Maps 

3D Irradiance/Illuminance Map shows the flux distribution on multiple surfaces 

in this crossed Czerny-Turner spectrometer model. 

The 3D Irradiance/Illuminance 

Map allows you to see the 

distribution of light on multiple 

surfaces at one time. The 

TrueColor mode is shown here. 

Grating 

Detector 

Collimating 

Mirror Focusing 

Mirror 



Path Sort Table and Display Selected Paths 

Analysis->Path Sort Table will open a table showing all the paths in a model. To 

display a path, select it in the Path Sort Table and then go to  

Analysis->Display Selected Paths 

Irradiance Map showing 

rays selected in the Path 

Sort Table 



Candela Plots 

Example Model - LED light with 7 LEDs and circular lens array 

“Receiver” Surface 



Polar Iso-Candela Plot 

To find the lumens in a given “zone”, go to Analysis->Display Selected Rays. 

Then go to Analysis->Select Rays to open the Select Rays dialog box. 

Enter 

Polar and 

Azimuth 

angles 

here to 

define the 

“zone” 

Display Selected 

Rays and Select 

Rays can also be 

selected by right 

clicking in the Polar 

Iso-Candela Plot 

window 



Making an IES File 

Right click in the Candela Plot window, choose SaveAs, and change the File 

Type to IESNA LM-63 (*.ies) 

Please see our 

October 2010 webinar 

for more information 

on IES and LDT files 

in TracePro 



The Flux Threshold Setting 



Flux Threshold 

•The Flux Threshold setting in TracePro determines when 

TracePro will stop keeping track of rays. 

 

•Once rays fall below the Flux Threshold they are terminated 

 

•The default setting for the Flux Threshold is 0.05, or 5% of the 

initial flux value of the ray 

 

•The Flux Threshold setting can be changed at  

•Raytrace->Raytrace Options->Thresholds 

 

•The Flux Report can be used to see if rays are falling below 

the Flux Threshold 



Flux Threshold 

Example Model - Simple light guide with LED source 



Flux Threshold 

Default Flux Threshold of 5% - 5.44 lumens out of 99.9 lumens are lost due to 

falling below the Flux Threshold. This is about 5.44% lost. 



Flux Threshold 

Flux Threshold of 0.5% - 0.234 lumens out of 99.9 lumens are lost due to falling 

below the Flux Threshold. Now only 0.23% is lost. 

Change Flux Threshold to 0.5% 



Apply Properties Before Copying 



Apply Properties Before Copying 

If you need to make an array of multiple objects, apply all properties to the base 

object before making the array. The properties will then be copied with the object. 

Use Move->Copy 

or Rotate->Copy 

to make the array 

Surface Source 

property copied 

with each new 

object 



Speeding Up Raytracing 



Speeding up Raytracing 

•Voxelization is a method of “allocating” the geometry in the 

model to specific zones to improve raytrace speed 

 

• Increasing the number of voxels improves raytrace speed at 

the expense of Audit speed 

 

•There are two types of voxels in TracePro, Octree and Uniform 

 

•The default is Uniform, which creates equally sized 3D voxels 

across the system 

 

•Octree voxelization concentrates voxels near objects and 

places fewer voxels in empty spaces in the model. This is best 

for models with large spaces between objects. For example, a 

luminaire and the floor. 



Speeding up Raytracing 

Voxel settings can be changed at Raytrace->Raytrace Options->Advanced  



Speeding up Raytracing 

Fluorescent fixture and floor model – 10 meters from fixture to floor 

10 meters 



Speeding up Raytracing 

Higher 

concentration 

of voxels 

around objects 

Lower 

concentration 

of voxels in 

empty space 

The Octree voxels version of this model raytraced 56% faster than the 

Uniform voxels version 

To view Voxels –  

View->Display Voxels 



Interactive Optimizer Tips 



Interactive Optimizer Tips 

Making Ray Fans and Beams in the Interactive Optimizer Sketch Window 

To make a Ray Fan, draw the 

initial ray by left clicking and 

dragging in the desired direction. 

Then press CTRL and make the 

fan by dragging left or right. 

To make a Beam, draw the initial 

ray by left clicking and dragging in 

the desired direction. Then press 

Shift and make the beam by 

dragging left or right. 



Interactive Optimizer Tips 

Relative Variables are defined as being relative to the position of the control 

point on the segment 



Interactive Optimizer Tips 

Relative Variables are defined as being relative to the position of the control 

point on the segment 

If you stop the 

optimization after the 

control point has 

moved, save the .SOD 

with the same name, 

and then re-open, the 

variable will be defined 

as relative to the new 

position of the control 

point.  

 

This could lead to the 

creation of bad 

geometry such as self 

intersecting segments. 



Interactive Optimizer Tips 

Absolute Variables are defined by absolute coordinates and are not tied to the 

current location of the control point 



Interactive Optimizer Tips 

Absolute Variables are defined by absolute coordinates and are not tied to the 

current location of the control point 

 

If you stop the 

optimization after the 

control point has 

moved, save the .SOD 

with the same name, 

and then re-open, the 

variable will still have 

the same “range” as 

initially defined. 



Current Promotions 



OSLO Promotion 

OSLO PROMOTION LIMITED TIME : APRIL 1, 2012 THROUGH JUNE 30, 2012 

Note: * Good for anyone who previously owned OSLO  *  Multiple license discounts do not apply * 

OSLO Node Locked License OSLO Promotional Pricing 

OSLO PREMIUM $1,500  

OSLO STANDARD $1,125  

OSLO LIGHT $750  

Example: 

OSLO Premium Node Locked two years out of support -- Cost to customer  $1500.00 

OSLO Premium Node Locked ten years out of support -- Cost to customer  $1500.00 
  

OSLO Network License OSLO Promotional Pricing 
OSLO PREMIUM $1,875  
OSLO STANDARD $1,500  

Customer who have purchased OSLO in the past, and are currently out of 

support ,can update to the current release of OSLO, OSLO 6.6, with one 

free year of support, for one low price. The price will depending on their 

edition of OSLO. Details of the promotion are shown below: 



Thank You 



Questions and Answers 



For Additional Information 

Please Contact: 

 
Lambda Research Corporation 

Littleton, MA 

978-486-0766 

www.lambdares.com 


