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• Presenter
Dave Jacobsen
Sr. Application Engineer
Lambda Research Corporation

• Moderator
Mike Gauvin
Vice President of Sales and Marketing
Lambda Research Corporation



Format

• A 25-30 minute presentation followed by 
a question and answer session

• Please submit your questions anytime 
using Question box in the GoToWebinar
control panel



Additional Resources

• Past TracePro Webinars

• http://www.lambdares.com/webinars

• TracePro Tutorial Videos

• http://www.lambdares.com/videos

• TracePro Tutorials

• http://www.lambdares.com/features/tracepro-tutorials

• Information on upcoming TracePro Training Classes

• http://www.lambdares.com/training/software-training

http://www.lambdares.com/webinars
http://www.lambdares.com/videos
http://www.lambdares.com/features/tracepro-tutorials
http://www.lambdares.com/training/software-training


Upcoming TracePro Training

• Jena, Germany

• Introduction to TracePro – October. 18-19, 2016

• Optimization with TracePro – October. 20-21, 2016

• Littleton, MA USA

• Introduction to TracePro – October. 25 -26, 2016

• Optimization with TracePro– October. 27-28, 2016



Latest TracePro Release

TracePro 7.7.2

Released April 1, 2016

TracePro 7.8 EA 

Currently available for download

Customers with current maintenance and support agreements can 
download this new release at:

http://www.lambdares.com/CustomerSupportCenter/index.php/trace-pro/current-release

http://www.lambdares.com/CustomerSupportCenter/index.php/trace-pro/current-release
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Agenda

• What is the TracePro RepTile property?

• Overview of the Texture Optimizer II

• Texture Types in the Texture Optimizer II

• Setting up the Texture Optimizer II

• The texture optimization process

• Using the Texture Optimizer II to apply texture features to curved 
surfaces

• Questions and Answers



TracePro RepTile Property



TracePro RepTile Property

What is RepTile?

• RepTile = Repetitive Tile

• Used to define repetitive microstructures in a convenient way

• Mathematical representations of the repetitive structure

• Allows for smaller file sizes as well as faster and easier modification 
of the structure

• RepTile properties may be applied to planar surfaces

• RepTile region is bounded by a rectangular, circular, or surface 
boundary

• Many geometry types may be made as either a Bump or Hole

• Requires TracePro Expert edition



TracePro RepTile Property

RepTile Property Editor : Define->Edit Property Data->RepTile Properties 



TracePro RepTile Property

RepTile Example – 1mm diameter hemisphere

Tile Size

Feature Dimensions

Bump or Hole



TracePro RepTile Property

Bump vs. Hole

Bump Hole



TracePro RepTile Property

Apply Properties - RepTile

RepTile 
Name

RepTile
Boundary



TracePro RepTile Property

Apply Properties - RepTile

The 
RepTile 

can have 
any 

Surface 
Property 

in the 
TracePro 
Surface 
Property 
Database



TracePro RepTile Property

To Display a RepTile: View ->Display RepTiles -> RepTiles & Boundary

2mm x 2mm tile



TracePro RepTile Property

To Display a RepTile: View ->Display RepTiles -> RepTiles & Boundary

2mm x 2mm tile

10 x 10mm Boundary



TracePro RepTile Property

Changing RepTile feature parameters

Change Feature Dimensions



TracePro RepTile Property

Changing RepTile feature parameters

Hemisphere is now 
2mm diameter



TracePro RepTile Property

Microlens array – Solid model vs RepTile

•16MB file
•6800+ Objects
•Modification requires 
remaking model

•17KB file
•1 Object
•To modify, just edit the 
RepTile property file



TracePro RepTile Property

RepTile Geometry Types



TracePro RepTile Property

RepTile Variation Types

• Constant - Enter data for one tile and it is repeated

• Variable ring/row - Enter data for all tiles for each row. Each row has all the 
same tiles

• Parameterized - Enter a formula for each geometry dimension and tile 
dimension

• Texture - Each geometry feature is placed free-form, by entering the coordinates 
and dimensions in a txt file



TracePro RepTile Property

Parameterized RepTile Variation Type Example

Height varying vs. column # and 
radius varying vs. row #



TracePro RepTile Property

RepTile Tile Types

Rectangular Tile
Staggered Rectangular 

Tile
Hexagonal Tile

Ring Tile
Staggered Ring 

Tile



TracePro RepTile Property

RepTile Examples – Backlight with no texture applied to bottom surface 
for light extraction



TracePro RepTile Property

RepTile Examples – Backlight with RepTile texture applied to bottom 
surface for light extraction



TracePro RepTile Property

RepTile Examples – PMMA Plastic Microlens Array made using RepTile 
Property



TracePro RepTile Property

RepTile Texture File

• Allows the User to define the location and feature type explicitly for each 
feature of the RepTile surface

• Allows mixing and matching of feature types. For example, a combination of 
spheres and cones could be defined

• Allowable geometry types: Sphere, Cone, Hip Roof, Ellipsoids, Enhanced 
Prism, Log, Flattened Cone, Pointed Cone, DMD Mirror, Block, Chiseled Log, 
Torus, Polygon

• Can be Bump or Hole

• Full description starting on page 7.108 of the TracePro User Manual



TracePro RepTile Property

RepTile Texture File

Feature type: 3 = Sphere, 2 = Cone

RepTile Texture File

Filename: C:\Users\djacobsen\Documents\Webinars\September 2011 Webinar, RepTile\Models

Date: 3/31/2010 12:00:00 AM

Version: 1.0

Texture Type: 0

Texture Features

3 -1 0 0 0.75 0.75

3 -1 4 4 0.5 0.5

3 -1 -4 -4 0.5 0.5

3 -1 -4 4 0.5 0.5

3 -1 4 -4 0.5 0.5

2 -1 2 2 1 0.1 45 0 0

2 -1 -2 -2 1 0.1 45 0 0

2 -1 -2 2 1 0.1 45 0 0

2 -1 2 -2 1 0.1 45 0 0

Bump or Hole: 1 = Bump, -1 = Hole

X-center Y-center

Feature parameters. Options 
will vary with feature selected.



TracePro RepTile Property

New RepTile property using the Texture File



TracePro RepTile Property

New RepTile property using the Texture File

Browse to location of the Texture File



TracePro RepTile Property

Applying the RepTile property



TracePro RepTile Property

RepTile property applied to surface in TracePro



TracePro RepTile Property

RepTile Summary

• RepTile allows you to create repetitive structures quickly and easily

• Numerous geometry types are available

• Several variations are available for tile positioning

• Model sizes are greatly reduced and raytrace times can be faster

• Geometry is easily changed by editing the RepTile property file

• Texture File allows you to explicitly define feature types and location and 
allows mixing and matching of feature types



TracePro Texture Optimizer II



TracePro Texture Optimizer II

What is the Texture Optimizer II

• Included with TracePro Expert in the Optimize menu

• Used with the RepTile property in TracePro

• Allows the user to define the surface boundary for the RepTile, the 
surface partitioning, the method for filling the cells, and the RepTile 
feature type

• The surface boundary can be defined using the name of the surface 
in TracePro, this allows for complex surface boundaries

• Surface partitioning options include uniform, grid, and ring options

• Numerous options are available for filling the cells

• 12 RepTile feature types available for use

• 2 main parts, the Dot Generator and the Optimization windows



TracePro Texture Optimizer II

Dot Generator window



TracePro Texture Optimizer II

Boundary Options



TracePro Texture Optimizer II

Boundary Options



TracePro Texture Optimizer II

Partition Options



TracePro Texture Optimizer II

Partition Options



TracePro Texture Optimizer II

In-cell fill options



TracePro Texture Optimizer II

In-cell fill options



TracePro Texture Optimizer II

Dot shape options



TracePro Texture Optimizer II

Dot shape options – Dot preview on



TracePro Texture Optimizer II

Dots display – on/off



TracePro Texture Optimizer II

Optimization window



TracePro Texture Optimizer II

Optimization window



Texture Optimizer II 
- Texture Types



Texture Optimizer II – Texture Types



Texture Optimizer II – Texture Types



Texture Optimizer II – Texture Types

Sphere



Texture Optimizer II – Texture Types

Cone



Texture Optimizer II – Texture Types

Hip Roof



Texture Optimizer II – Texture Types

Ellipsoid



Texture Optimizer II – Texture Types

Log



Texture Optimizer II – Texture Types

Pointed Cone



Texture Optimizer II – Texture Types

Flattened Cone



Texture Optimizer II – Texture Types

Asphere



Texture Optimizer II – Texture Types

Torus



Texture Optimizer II – Texture Types

Enhanced Prism



Texture Optimizer II – Texture Types

Polygon



Texture Optimizer II – Texture Types

Model



Texture Optimizer II – Texture Types

Model



Texture Optimizer II – Texture Types

Model



Texture Optimizer II – Texture Types

Model



Setting up the Texture Optimizer II



Setting up the Texture Optimizer II

Typical Workflow

Build model in TracePro and 
define Sources and Target

Define Initial Texture in Dot 
Generator Window

Export Texture File and make 
a RepTile Property in 

TracePro using Texture File

Apply RepTile to the model 
and run an initial raytrace

Set up Optimization 
parameters

Test model to make sure 
RepTile and Irradiance Map 

are aligned

Run the Optimization

Update the TracePro model 
and verify the results



Setting up the Texture Optimizer II

TracePro model

Light Guide
Target

LED



Setting up the Texture Optimizer II

TracePro model – Acrylic Light Guide with “Bottom” surface named



Setting up the Texture Optimizer II

TracePro model – LED model with Surface Source Property



Setting up the Texture Optimizer II

TracePro model – “Target” with “Receiver” surface named 



Setting up the Texture Optimizer II

TracePro model – Initial Illuminance Map – Log Scale



Setting up the Texture Optimizer II

Open the Texture Optimizer II 



Setting up the Texture Optimizer II

Texture Optimizer II 



Setting up the Texture Optimizer II

Select Surface for Boundary type and then enter “Bottom” for Face Name 
and “Light Guide” for Object Name. Click OK. 



Setting up the Texture Optimizer II

Bottom surface of the light guide is now used as the boundary



Setting up the Texture Optimizer II

Select Uniform for Partition, enter 250 for Cells, and then click Generate



Setting up the Texture Optimizer II

Select Sphere for Dot Shape, Hole for Bump Sign, and enter 0.05 for the 
Radius and Height. Units are mm.



Setting up the Texture Optimizer II

Select Assigned density-Uniform for the In-cell setting, enter 0.25 for the 
Density, and then click Generate



Setting up the Texture Optimizer II

Click Dots to display the dots. The scroll wheel can be used to zoom in 
and out.



Setting up the Texture Optimizer II

Export the Texture File by going to Export->TracePro Texture and then 
saving the resulting .txt file



Setting up the Texture Optimizer II

Save the Texture Optimizer II file by going to File->Save as..   
The file extension is .dgf. This will save all of the settings 
defined in the texture optimizer for future use.



Setting up the Texture Optimizer II

Make a new RepTile Property in TracePro by going to Define->Edit 
Property Data->RepTile Properties



Setting up the Texture Optimizer II

Select a Catalog or make a new one using Add Catalog. Click Add 
Property. Give the property a Name and select Texture File for the 
Variation Type. Click OK.



Setting up the Texture Optimizer II

Click the Browse icon next to File: and then browse to the Texture File that 
was previously saved and then click Open



Setting up the Texture Optimizer II

Select Hole and then enter 0.1 for Def Width and Def Height Tile 
Parameters. Click the disk icon to save the RepTile property.



Setting up the Texture Optimizer II

Apply the RepTile to the Light Guide model in TracePro.



Setting up the Texture Optimizer II

Select the surface named “Bottom” of the “Target” object, right click, 
choose Properties, and then choose RepTile



Setting up the Texture Optimizer II

Select the Catalog and Name for the RepTile property that was previously 
saved



Setting up the Texture Optimizer II

Select Default for the Surface Catalog and Flat white paint for the Surface 
Name. This will apply the flat white paint property to the RepTile features.



Setting up the Texture Optimizer II

Enter 0.05 for the Depth and choose Use Surface Bounds for the 
Boundary and Orientation. Click Apply to apply the RepTile property.



Setting up the Texture Optimizer II

Display the RepTile by going to View->Display RepTiles->RepTiles & 
Boundary



Setting up the Texture Optimizer II

Display the RepTile by going to View->Display RepTiles->RepTiles & 
Boundary



Setting up the Texture Optimizer II

Display the Illuminance Map for the “Receiver” surface of the “Target”



Setting up the Texture Optimizer II

Adjust the Normal and Up Vectors for the Irradiance/Illuminance Map so 
that the plot matches the orientation in the Texture Optimizer II



Setting up the Texture Optimizer II

We are now ready to start the optimization process



The texture optimization process



Texture Optimization

Open the optimization window by going to Action->Optimization



Texture Optimization

Texture Optimizer II Optimization window



Texture Optimization

Enter “Receiver” for the Target Name. Clicking the green checkmark will 
verify that the surface exists



Texture Optimization

Choose Random distribution for Distribution. This option will optimize the 
texture pattern by varying the texture density in each cell.



Texture Optimization

Select Texture file for the Export Target and then browse to the location of 
the saved Texture File



Texture Optimization

Set the Initial Mode to Start as initial density. Set the Initial Density to 0.1 
and the Max. Density to 0.75.



Texture Optimization

Browse to a location to for the Results Folder. This is where the results will 
be saved. Define a Prefix that will be used for each file.



Texture Optimization

Verify the Dot Shape parameters



Texture Optimization

Click Start to start the optimization process



Texture Optimization

Optimization Log – Best result was the 5th iteration

Irradiance

Error Value

Error Value

Flux



Texture Optimization

Dot_pattern.txt for best result in Results folder



Texture Optimization

Update TracePro RepTile property using the best result Dot_pattern.txt file



Texture Optimization

Initial vs. Optimized RepTile Texture Pattern

Initial RepTile Texture Pattern Optimized RepTile Texture Pattern



Texture Optimization

Re-run the raytrace to check the results – Illuminance Map

Initial Illuminance Map Optimized Illuminance Map



Texture Optimization

Re-run the raytrace to check the results – 3D Illuminance Map

Initial 3D Illuminance Map Optimized 3D Illuminance Map



Applying texture to a curved surface



Texture on a curved surface

Applying Texture to a Curved Surface with the Texture Optimizer II

• The Texture Optimizer II allows the user to apply a texture to a curved 
surface

• The texture is applied as a real geometry and not a RepTile property

• The boundary, partitions, dot shape, and cell densities can be defined 
in the Texture Optimizer II

• Boolean subtract and unite options are available for making holes or 
bumps

• Because the texture is modeled as real, 3D geometry, there can be a 
limit to the number of texture features applied. More texture features 
will take more time.



Texture on a curved surface

Curved Light Guide model in TracePro

Light Guide
LED

LED

Target



Texture on a curved surface

The texture will be applied to the “Bottom” surface of the Light Guide



Texture on a curved surface

Select Surface(uv) for the Boundary, enter the name of the Surface in the 
dialog box, and then click OK



Texture on a curved surface

Select Surface(uv) for the Boundary, enter the name of the Surface in the 
dialog box, and then click OK



Texture on a curved surface

Select the Partition type and number of Cells. Example below is Uniform 
partition with 100 cells.



Texture on a curved surface

Define the Dot Shape. Example below is a Flatted cone, 0.5mm high with 
an end radius of 0.5mm and a 45-degree cone angle.



Texture on a curved surface

Choose the In-cell method and the density. Click Generate to generate the 
dots. Turn on Dots to see the dots. The example below uses Assigned 
density-Uniform for the In-cell method and 0.25 for the Density.



Texture on a curved surface

Select Export->Real geometries



Texture on a curved surface

Enter the Surface Name, Object Name, and Boolean type and then click 
Export.



Texture on a curved surface

Results in TracePro



Texture on a curved surface

Results in TracePro



Summary and Questions



Summary and Questions

The TracePro RepTile property and Texture Optimizer II allows:

 A fast, accurate, and efficient way to model repetitive microstructures on 

light guides and backlights

Numerous options for feature types

Quick and easy optimization of RepTile texture patterns on light guide and 

backlights for improved uniformity

 The ability to add texture features to curved surfaces as real geometry

For more information or to sign up for our free 30-day trial please visit us at:

www.lambdares.com

Phone: +1 978-486-0766         E-mail: sales@lambdares.com

http://www.lambdares.com/
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